Hello everybody,
I was reading the section about java activities and process variables in the userguide and
wondering about some things.
In a java or a custom activity I could use
Object getVariable(String key);
to retrieve the values of process variables and then I could go use them as arguments for
method calls.
But that means that if I changed the names of the process variables I would need to change
the implementation of the java or custom activity, too. So wouldn't it be more
convient to be able to specifiy process variables in the process definition which would be
passed as arguments? So in case the process variable names changed just the process
definition would need need changes but the java class wouldn't need to be touched?
If I got it wrong I'd be happy for some clarifying words. If not this seems to turn
out to be a discussion for the dev forum, right?
I was also wondering why you can specify the method name for a java activity in the GPD
but not the number of arguments.
Sebastian
View the original post :
http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4259029#...
Reply to the post :
http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&a...