[
https://jira.jboss.org/jira/browse/JBSEAM-1891?page=com.atlassian.jira.pl...
]
Seam Framework XMLRPC commented on JBSEAM-1891:
-----------------------------------------------
1) CacheProvider should be implemented as an abstract base class with an instance method
on.
2) The decision about which cache provider to use should be defaulted based on what
classes are available and precedence
3) cfgResourceName - the variable name is wrong, it should be configurationFile
4) the configurationFile should be defaulted based on provider
5) the page fragment cache should use the cache provider installed, with the option to
override if needed, the PageFragmentCache class is then unnecessary
6) Versions of dependencies are declared in root.pom.xml not core.pom.xml
7) Why are methods like start, stop,
8) Why addOrUpdate, not put?
9) Exceptions should *not be wrapped*
10) I didn't review the docs.
Otherwise, looks great - thanks
Decouple page fragment caching from JBoss Cache
-----------------------------------------------
Key: JBSEAM-1891
URL:
https://jira.jboss.org/jira/browse/JBSEAM-1891
Project: Seam
Issue Type: Task
Components: Core, JSF Controls
Reporter: Christian Bauer
Fix For: 2.1.0.BETA2
Attachments: alternative_cache_provider_for_the_page_fragment_cache.patch
The code in UICache and PojoCache only works with this component:
return (org.jboss.cache.aop.PojoCache) Component.getInstance(PojoCache.class,
ScopeType.APPLICATION);
Make this generic so that other cache providers can be used.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
https://jira.jboss.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira