On Thu, Dec 20, 2012 at 2:16 PM, Christos Vasilakis <cvasilak(a)gmail.com> wrote:
Hi team,
as part of the API overhaul ticket[1] for the next CR1 release, inside of the following
classes we have a getter, to get an actual object by its name:
• AGPipeline
• AGDataManager
• AGAuthenticator
Example
- (id<AGAuthenticationModule>)get:(NSString *)moduleName
In in the iOS land, a get* method by convention is used to fill the parameters of the
method with a value, for example see [2] from apple documentation . What we propose is a
rename of these methods,
for example:
+1 on renaming ;-)
- (id<AGAuthenticationModule>)moduleWithName:(NSString
*)moduleName
I am not 100% sure, but that _could_ work for receiving an authModule.
(perhaps '-authModuleWithName:' ?)
For AGPipeline, how about:
-pipeWithName:
For AGDataManager, how about
-storeWithName:
-M
--
Matthias Wessendorf
blog:
http://matthiaswessendorf.wordpress.com/
sessions:
http://www.slideshare.net/mwessendorf
twitter:
http://twitter.com/mwessendorf