Looking at the Class Loading discussion, part of the confusion is that CacheDelegate
doesn't do what it says. Delegate is normally used to described the thing that a
decorator delegates calls to.
To avoid confusion, I would like to rename CacheDelegate. I would propose it ComposedCache
(as it's a Cache impl which is composed of various services which actually implement
the Cache itself). Alternatively we could go with CacheImpl.
Any concerns?