I agree with all except for "create". It implies invention, or
something. I think "add" is generally more appropriate.
On 01/14/2011 03:56 AM, Heiko Braun wrote:
I would stick to "read" as well.
Simply to avoid ambiguity across API clients.
I.e. a REST "GET" means you have no obligations when doing the call,
a Java "get()" imposes that most of the time, but not necessarily (think
factory pattern).
IMO choosing explicit operation names is a good idea.
I.e. I would prefer:
- "read" over "get"
- "write" over "set"
- "create" over "set"
- "remove" over "set"
I hope that explains what I was trying to say.
Ike
On Jan 13, 2011, at 11:31 PM, Kabir Khan wrote:
>
> The main reason I did 'read' was that at the time it felt weird to have
GlobalDescriptions.getGetXXXX(), so I can change that.
> I assume you want to keep f) as "read" or do you want that to be
"get" as well?
_______________________________________________
jboss-as7-dev mailing list
jboss-as7-dev(a)lists.jboss.org
https://lists.jboss.org/mailman/listinfo/jboss-as7-dev
--
- DML