[Beginners Corner] - suggestions on adding private messaging to existing applicat
by bleach
We have an existing web app running on JBoss which allows users to logon and view data.
We now want to roll out a component which allows users to send messages to us. However some of the data that would be included in the message would be confidential so email won't work. What would be perfect is the private message feature built into most forums.
We don't want to re-invent the wheel so we are trying to find out if there is an open source module we can re-use.
Ideally, the solution would consist of a DB design and an API for placing and retrieving messages. To maintain consistent look and feel we want to have complete control over the UI.
The current app is JSP / Struts on JBoss 4.05
None of us have experience other than Java so PHP etc are going to be non-starters.
Can anyone provide some pointers on existing code we can use, or even a design pattern we could use to shortcut the development.
Thanks
View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4053930#4053930
Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4053930
19Â years, 3Â months
[Tomcat, HTTPD, Servlets & JSP] - http://java.sun.com/jsf/html cannot be resolved
by Hattifnat
Hi!
I'm using JBoss AS 4.2.0 and deploying a WAR file consisting of JSP and JSF pages. I use Apache MyFaces Tomahawk 1.1.6, which is in my WAR's WEB-INF/lib directory. I do not use MyFaces Core - i want to use the JBoss's bundled JSF libraries. The problem is: deployment of the WAR goes fine, the main index.jsp page works fine, but when I want to enter a JSF page, a following exception is thrown on the JBoss console and the page is blank.
org.apache.jasper.JasperException: The absolute uri: http://java.sun.com/jsf/html cannot be resolved in either web.xml or the jar files deployed with this application
| at org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:51)
| at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:409)
| at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:116)
| at org.apache.jasper.compiler.TagLibraryInfoImpl.generateTLDLocation(TagLibraryInfoImpl.java:315)
| at org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:148)
| at org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:420)
| at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:476)
| at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1426)
| at org.apache.jasper.compiler.Parser.parse(Parser.java:133)
| at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:216)
| at org.apache.jasper.compiler.ParserController.parse(ParserController.java:103)
| at org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:167)
| at org.apache.jasper.compiler.Compiler.compile(Compiler.java:306)
| at org.apache.jasper.compiler.Compiler.compile(Compiler.java:286)
| at org.apache.jasper.compiler.Compiler.compile(Compiler.java:273)
| at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:566)
| at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:311)
| at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:320)
| at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
| at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
| at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
| at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
| at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:687)
| at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:469)
| at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:403)
| at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:301)
| at com.sun.faces.context.ExternalContextImpl.dispatch(ExternalContextImpl.java:408)
| at com.sun.faces.application.ViewHandlerImpl.executePageToBuildView(ViewHandlerImpl.java:439)
| at com.sun.faces.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java:114)
| at com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:106)
| at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:251)
| at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:144)
| at javax.faces.webapp.FacesServlet.service(FacesServlet.java:245)
| at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
| at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
| at org.apache.myfaces.webapp.filter.ExtensionsFilter.doFilter(ExtensionsFilter.java:147)
| at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
| at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
| at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
| at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
| at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
| at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
| at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
| at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
| at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
| at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
| at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
| at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:156)
| at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
| at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:241)
| at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
| at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:580)
| at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
| at java.lang.Thread.run(Thread.java:595)
My web.xml file is such:
<?xml version="1.0" encoding="UTF-8"?>
| <web-app xmlns="http://java.sun.com/xml/ns/j2ee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd" version="2.4">
|
| <servlet>
| <servlet-name>jsp</servlet-name>
| <servlet-class>org.apache.jasper.servlet.JspServlet</servlet-class>
| <init-param>
| <param-name>compilerTargetVM</param-name>
| <param-value>1.5</param-value>
| </init-param>
| <init-param>
| <param-name>compilerSourceVM</param-name>
| <param-value>1.5</param-value>
| </init-param>
| </servlet>
|
| <filter>
| <filter-name>extensionsFilter</filter-name>
| <filter-class>org.apache.myfaces.webapp.filter.ExtensionsFilter</filter-class>
| <init-param>
| <description>Set the size limit for uploaded files.
| Format: 10 - 10 bytes
| 10k - 10 KB
| 10m - 10 MB
| 1g - 1 GB</description>
| <param-name>uploadMaxFileSize</param-name>
| <param-value>2m</param-value>
| </init-param>
| <init-param>
| <description>Set the threshold size - files
| below this limit are stored in memory, files above
| this limit are stored on disk.
|
| Format: 10 - 10 bytes
| 10k - 10 KB
| 10m - 10 MB
| 1g - 1 GB</description>
| <param-name>uploadThresholdSize</param-name>
| <param-value>100k</param-value>
| </init-param>
| </filter>
| <filter-mapping>
| <filter-name>extensionsFilter</filter-name>
| <url-pattern>*.jsf</url-pattern>
| </filter-mapping>
| <filter-mapping>
| <filter-name>extensionsFilter</filter-name>
| <url-pattern>/faces/*</url-pattern>
| </filter-mapping>
|
| <servlet>
| <servlet-name>Faces Servlet</servlet-name>
| <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
| <load-on-startup>1</load-on-startup>
| </servlet>
|
| <servlet-mapping>
| <servlet-name>Faces Servlet</servlet-name>
| <url-pattern>*.jsf</url-pattern>
| </servlet-mapping>
|
| <welcome-file-list>
| <welcome-file>index.jsp</welcome-file>
| </welcome-file-list>
| </web-app>
My JSF page (called "page.jsp" but accessed as "page.jsf")
<%@ page language="java" contentType="text/html; charset=UTF-8" pageEncoding="UTF-8"%>
| <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
| <%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %>
| <%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>
| <%@ taglib uri="http://myfaces.apache.org/tomahawk" prefix="t" %>
|
| <html>
| <head>
| <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
| <link rel="stylesheet" href="styles.css" type="text/css">
| <title></title>
| </head>
| <body>
| <table>
| <tr>
| <td id="menu">
| <%@include file="menu.html" %>
| </td>
| <td id="main">
| <f:view>
|
| <h:form id="some_id">
| HELLO
| </h:form>
| </f:view>
| </td>
| </tr>
| </table>
| </body>
| </html>"
The same WAR, but with MyFaces included in WEB-INF/lib (MyFaces API and Impl) works fine on Tomcat 5.5.23. Can anybody help me?
View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4053927#4053927
Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4053927
19Â years, 3Â months
[JBoss jBPM] - jbpm using oracle DB probleme
by lethrech
hi,
i m using jbpm 3.1.3 whith oracle9i DB, i have created my schema and configured my datasource but i have the following error when i start my jboss4.0.4 :
2007 06 13 - 12:00:41 ERROR ?.? [ORA-00923: Mot-clé FROM absent à l'emplacement prévu
| ]]
| 2007 06 13 - 12:00:41 ERROR ?.? [ORA-00923: Mot-clé FROM absent à l'emplacement prévu
| ]
| 2007 06 13 - 12:00:41 INFO org.apache.commons.logging.impl.Log4JLogger.error [2007 06 13 - 12:00:41 ERROR ?.? [org.hibernate.exception.SQLGrammarException: could not execute query using iterate]]
| 2007 06 13 - 12:00:41 ERROR ?.? [org.hibernate.exception.SQLGrammarException: could not execute query using iterate]
| 2007 06 13 - 12:00:41 INFO org.apache.commons.logging.impl.Log4JLogger.info [2007 06 13 - 12:00:41 INFO ?.? [runtime exception while executing timers]
| org.jbpm.JbpmException: couldn't find timers from the database
| at org.jbpm.db.SchedulerSession.findTimersByDueDate(SchedulerSession.java:99)
| at org.jbpm.scheduler.impl.SchedulerThread.executeTimers(SchedulerThread.java:107)
| at org.jbpm.scheduler.impl.SchedulerThread.run(SchedulerThread.java:71)
| Caused by: org.hibernate.exception.SQLGrammarException: could not execute query using iterate
| at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:67)
| at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelper.java:43)
| at org.hibernate.loader.hql.QueryLoader.iterate(QueryLoader.java:424)
| at org.hibernate.hql.ast.QueryTranslatorImpl.iterate(QueryTranslatorImpl.java:380)
| at org.hibernate.engine.query.HQLQueryPlan.performIterate(HQLQueryPlan.java:224)
| at org.hibernate.impl.SessionImpl.iterate(SessionImpl.java:1192)
| at org.hibernate.impl.QueryImpl.iterate(QueryImpl.java:46)
| at org.jbpm.db.SchedulerSession.findTimersByDueDate(SchedulerSession.java:93)
| ... 2 more
| Caused by: java.sql.SQLException: ORA-00923: Mot-clé FROM absent à l'emplacement prévu
my data source is as follow:
| <datasources>
| <local-tx-datasource>
| <jndi-name>jbpmDS</jndi-name>
| <connection-url>jdbc:oracle:thin:@192.168.10.134:1521:DB1</connection-url>
| <driver-class>oracle.jdbc.OracleDriver</driver-class>
| <user-name>jbpmtest</user-name>
| <password>jbpmtest</password>
| <min-pool-size>5</min-pool-size>
| <max-pool-size>20</max-pool-size>
| <idle-timeout-minutes>0</idle-timeout-minutes>
| <prepared-statement-cache-size>32</prepared-statement-cache-size>
| <metadata>
| <type-mapping>Oracle9i</type-mapping>
| </metadata>
| </local-tx-datasource>
|
| </datasources>
|
can you help me
thank s a lot
View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4053919#4053919
Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4053919
19Â years, 3Â months