I tracked the problem within the debugger and found the source of the error. Obivously it
is a different naming scheme they have in JBoss 5.
Looking at the constructor of Hibernate's SessionFactoryImpl(), I saw the creation of
a local variable named 'cacheRegionPrefix' (String cacheRegionPrefix =
settings.getCacheRegionPrefix()), which is then later used as argument for a cache region
name.
Now, in JBoss this cacheRegionPrefix results into something like this:
| persistence.unit:unitName=dpjwApp-ear-1.0.ear/dpjw-core-1.0.jar#dpjw_office.
|
whereas in JBoss 4.2.3 it was
| dpjwApp-ear-1_0_ear,dpjw_office.
| .
Carlo
Nice to see: BUT what can WE do here???
View the original post :
http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4195084#...
Reply to the post :
http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&a...