Emanuel Muckenhuber [
http://community.jboss.org/people/emuckenhuber] replied to the
discussion
"controller.uninstall() fails when overriding the KernelControllerContext name"
To view the discussion, visit:
http://community.jboss.org/message/539350#539350
--------------------------------------------------------------
Ales Justin wrote:
Why don't you rather use alias then change original name in the middle of bean's
lifecycle?
Imo, the name should actually be made immutable, specially after the context is
installed.
Well the thing is that i'm not changing the name during the lifecycle
- it's the kernel InstallAction, which does that. I just override the original context
name before i call install(), since BMD only allows Strings as a name.
--------------------------------------------------------------
Reply to this message by going to Community
[
http://community.jboss.org/message/539350#539350]
Start a new discussion in JBoss Microcontainer at Community
[
http://community.jboss.org/choose-container!input.jspa?contentType=1&...]