Rename CronEvent to improve readability?
----------------------------------------
Key: SEAMCRON-10
URL:
https://issues.jboss.org/browse/SEAMCRON-10
Project: Seam Cron
Issue Type: Task
Reporter: Peter Royle
Assignee: Peter Royle
Priority: Minor
Fix For: 3.0.0.Alpha1
Originally scheduled observer methods were quite readable, eg:
public void doStuff(@Observes @Scheduled("10:00") Event e) { ... }
However, due to possible confusion between cron.Event and javax.Event it became:
public void doStuff(@Observes @Scheduled("10:00") CronEvent ce) { ... }
which seems kind of awkward and redundant. Perhaps if we renamed CronEvent to Instant,
which doesn't conflict with anything, the readability might be improved like so:
public void doStuff(@Observes @Scheduled("10:00") Instant i) { ... }
Also, Instant better represents the nature of the thing being passed in, as nothing has
actually happened yet. My main concern is that it's not as memorable as Event, but
then is CronEvent?
... not sure ...
--
This message is automatically generated by JIRA.
For more information on JIRA, see:
http://www.atlassian.com/software/jira