Pete R - do you want to take this, or do you want me to do it?
BTW, to make use in JavaSE easier (especially to avoid RSI by typing crazy long -cp
entries) we should add a single jar that includes all deps
On 21 Nov 2009, at 18:36, Gavin King wrote:
On Sat, Nov 21, 2009 at 10:47 AM, Pete Muir <pmuir(a)redhat.com>
> * I would prefer to not actually bootstrap Weld core inside the Weld constructor (I
believe this should be an explicit step), hence the boot() method. We could rename this to
initialize() for example. Opinions?
Fine by me. Especially since that at some stage we will need to pass
some kind of settings before booting.
> * What API do we want to expose to allow people to get hold of an Instance<?> ?
IMO we need more syntatic sugar than offered by BeanManager. Do we want to just allow
access to Instances (as above)?
Stick the following two methods on the object returned by initialize():
So I can do:
Weld weld = new Weld().initialize();
weld.event().select(Bar.class).fire( new Bar() );