Hardy and I were wondering whether the method
name ExecutableDescriptor#areParametersConstrained() is the best choice.
The name seems a bit unintuitive, when e.g. looking via auto-completion for
boolean getter methods which typically start with "is" or "has".
* "isParameterConstrained()" (as in "is constrained on at least one
* "hasConstrainedParameters()" would be better alternatives?
The latter would also nicely match with