https://github.com/kabir/jboss-as/commits/detyped2
contains the fixes. I did most of what you suggested, but left out some other bits - see
below
On 13 Jan 2011, at 22:31, Kabir Khan wrote:
On 13 Jan 2011, at 22:08, Brian Stansberry wrote:
> Kabir,
>
> A couple more comments re: [1] following the discussion in #jboss-as7:
>
> 1) Instead of or in addition to the READ_ATTRIBUTE_OF_TYPE op, I was
> looking for something like:
>
> {
> "op" => "read-children-names",
> "op-addr" => [
> ("profile" => "production")
> ],
> "child-type" => "subsystem"
> }
>
> which would then return a list of the names of all subsystems.
Your wish shall be granted :-)
This is done
>
> 2) Assume people are going to have to type some of these a lot, so let's
> find short names for these operations:
Most of these are done
>
>
> a) public static final String READ_ATTRIBUTES_OF_TYPE_OPERATION =
> "read-attributes-of-type-operation";
>
> "read-attributes-of-type" if the behavior remains the same, else
> "read-children-names"
I got rid of the original and replaced it with
>
> b) public static final String READ_NAMED_ATTRIBUTE_OPERATION =
> "read-named-attribute-operation";
>
> "read-attribute"
>
> c) public static final String READ_NODE_DESCRIPTION_OPERATION =
> "read-node-description-operation";
>
> "read-resource-description"
>
> d) public static final String READ_OPERATION_OPERATION =
> "read-operation-operation";
>
> "read-operation-description"
>
> e) public static final String READ_OPERATIONS_SUMMARY_OPERATION =
> "read-operations-summary-operation";
>
> "read-operation-names"
>
> f) public static final String READ_SUB_MODEL_OPERATION =
> "read-sub-model-operation";
>
> "read"
read-sub-model
>
> For this last one, we could add a required=false "attribute" param, make
> the existing "recursive" property required=false, and collapse b) and f)
> into a single operation named "read". WDYT?
Sounds reasonable
I am not so sure about merging these two any more. After some
thought I feel that attributes/nodes should be separate
> I have a desire to replace "read" with "get"
in all of the above, but
> that may be too many years of Java development talking.
The main reason I did 'read' was that at the time it felt weird to have
GlobalDescriptions.getGetXXXX(), so I can change that.
I assume you want to keep f) as "read" or do you want that to be
"get" as well?
I kept 'read-' following Heiko/Ike's comment