Hi,
I think the name changes are definitely a step into the right direction. I
am still not
convinced that the whole API fis not overcomplicated, but if we go down
this path I give
the new names a +1. Changing ValidatorFactoryBuilder to Configuration is
also a good idea
since I believe we have too many ValidationXXX and ValidatorXXX classes.
It's damn hard to
keep things apart there.
I am also wondering if we should rename the methods on the
Configuration object (former ValidatorFactoryBuilder):
- messageResolver => useMessageResolver
- providerResolver => useProviderResolver
- traversableResolver => useTraversableResolver
- customConfiguration => useCustomConfiguration
- constraintFactory => useConstraintFactory
I guess if you really want to go down the 'fluent' API path it makes
sense, even though I
don't have any strong feelings about it.
--Hardy