Currently we utilize 3 different ServiceRegistry types within Hibernate
and I wanted to hopefully get some consensus on their names.
1) org.hibernate.service.internal.BootstrapServiceRegistryImpl. It
contains services that have to be known up front. Currently this is
limited to ClassLoaderService and IntegratorService. Personally I think
this one is already perfectly named per its intent/purpose.
2) org.hibernate.service.internal.BasicServiceRegistryImpl. The naming
of this one has caused some confusion for at least one person I know.
And I agree that the naming here is not best. Some other names proposed
have been "standard service registry" or "main service registry".
This
is the main registry in that it holds most of the services. It has the
bootstrap registry as its parent, and the
SessionFactoryServiceRegistryImpl uses this as its parent.
3) org.hibernate.service.internal.SessionFactoryServiceRegistryImpl.
This is responsible for holding services that need access to the
SessionFactory during their init. Again, I think this is a good name
for its function, but am open to other suggestions. BTW, currently this
only includes the event listener service though I see this expanding a
little as we finish up the metamodel changes to include a few more services.
A related discussion, if we decided to rename any of these, is whether
that renaming warrants another CR release.
--
steve(a)hibernate.org
http://hibernate.org