]
Michael Musgrove updated JBTM-3177:
-----------------------------------
Status: Resolved (was: Pull Request Sent)
Resolution: Done
Rename lra-filters to narayana-lra
----------------------------------
Key: JBTM-3177
URL:
https://issues.jboss.org/browse/JBTM-3177
Project: JBoss Transaction Manager
Issue Type: Bug
Components: LRA
Affects Versions: 5.9.6.Final
Reporter: Martin Stefanko
Assignee: Martin Stefanko
Priority: Major
Fix For: 5.next
As lra-filters is the main (and only) dependency that users will typically come in
contact with, it would be beneficial for it to have a generic name to avoid questions like
why do I need to include lra-filters and not lra-client? It's easier to explain and
read:
{code:xml}
<dependency>
<groupId>org.eclipse.microprofile.lra</groupId>
<artifactId>microprofile-lra-api</artifactId>
<version>1.0-RC1</version>
</dependency>
<dependency>
<groupId>org.jboss.narayana.rts</groupId>
<artifactId>narayana-lra</artifactId>
<version>5.9.6.Final</version>
</dependency>
{code}
While this can lead to unwanted questions:
{code:xml}
<dependency>
<groupId>org.eclipse.microprofile.lra</groupId>
<artifactId>microprofile-lra-api</artifactId>
<version>1.0-RC1</version>
</dependency>
<dependency>
<groupId>org.jboss.narayana.rts</groupId>
<artifactId>lra-filters</artifactId>
<version>5.9.6.Final</version>
</dependency>
{code}