Do you mind breaking them into separate emails?
Kinda hard to debate on three different things in one email
-M
On Thu, Dec 20, 2012 at 2:16 PM, Christos Vasilakis <cvasilak(a)gmail.com> wrote:
Hi team,
as part of the API overhaul ticket[1] for the next CR1 release, the
following are some small changes in the API that we are proposing.
1.
To be in pair with iOS convention, we are suggesting a change for the config
options to be set by properties instead of the current convention.
That it from:
[config name:@"foo"];
to be:
config.name = @"foo";
A ticket has already been opened, see [2]
2.
Change the property URL of the AGPipe object to be an NSURL instead of a
String.
That is from:
@property (nonatomic, readonly) NSString *URL
to be:
@property (nonatomic, readonly) NSURL *URL
A ticket has already been opened, see [3]
3.
Per se with iOS convention of construction, rename the current init methods
from:
-(id) init:(NSURL*) baseURL;
+(id) pipeline:(NSURL*) baseURL;
to:
-(id) initWithBaseURL:(NSURL*) baseURL;
+(id) pipelineWithBaseURL:(NSURL*) baseURL;
A ticket has already been opened for this, see [4]
What do you think?
Thanks,
Christos
[1]
https://issues.jboss.org/browse/AEROGEAR-763
[2]
https://issues.jboss.org/browse/AEROGEAR-751
[3]
https://issues.jboss.org/browse/AEROGEAR-764
[4]
https://issues.jboss.org/browse/AEROGEAR-766
_______________________________________________
aerogear-dev mailing list
aerogear-dev(a)lists.jboss.org
https://lists.jboss.org/mailman/listinfo/aerogear-dev