Overall I think it's good.
some proposals (when followed by a ? my feeling is that the original
name is as good or better)
Generally, I've inversed names to make the most important word first.
Indexer => MassIndexer
objectLoadingThreads => threadsToLoadObjects
objectLoadingBatchSize => batchSizeToLoadObjects
documentBuilderThreads => threadsForSubsequentFetching,
threadsForFetching
indexWriterThreads => threadsIndexingToLucene
cacheMode //when would you need something different than Ignore? Also,
I'd rather get CacheMode be a Search class to keep the independance
wrt Hibernate Core
optimizeAtEnd => optimizeOnFinish
optimizeAfterPurge
purgeAllAtStart => purgeBeforeIndexing ?, purgeAllOnStart, purgeOnStart
limitObjects => indexObjectsUpTo, indexFirstObjectsUpTo,
limitIndexedObjectsTo //what's the use case?
start => Future should get actually return some stats? We can delay
that but I don't like the JavaDoc claiming that we will always return
null
startAndWait => execute ?
WTY?
On Jun 30, 2009, at 16:18, Sanne Grinovero wrote:
Hello,
I need some comments about the batch indexing API, so that I can
stabilize it and write the documentation;
I might even blog about it :-)
Here is the current sketch:
http://fisheye.jboss.org/browse/Hibernate/search/trunk/src/main/java/org/...
Emmanuel I remember you wanted to give me directions to make this
"fluent", and you didn't like the method names.
ideas?
Sanne
_______________________________________________
hibernate-dev mailing list
hibernate-dev(a)lists.jboss.org
https://lists.jboss.org/mailman/listinfo/hibernate-dev