[JBoss JIRA] Created: (JBCACHE-701) PojoCache to revisit usage of get with gravitation
by Ben Wang (JIRA)
PojoCache to revisit usage of get with gravitation
--------------------------------------------------
Key: JBCACHE-701
URL: http://jira.jboss.com/jira/browse/JBCACHE-701
Project: JBoss Cache
Issue Type: Task
Security Level: Public (Everyone can see)
Components: PojoCache
Reporter: Ben Wang
Assigned To: Ben Wang
Fix For: POJOCache
Currently we have in couple places to trigger data gravitation (for buddy replication) in PojoCache. But this is still prone to error (and may be inefficient as well) becuase of the possibility of recursive call. Is it possible that we do this from the user code instead? That is, before we go to PojoCache, can we do get(region, dataGravitation) to gravitate all data to this node first?
Let's check this with Brian.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
19 years
[JBoss JIRA] Created: (JBMICROCONT-109) Support direct registration of beans without a StandardMBean wrapper
by Brian Stansberry (JIRA)
Support direct registration of beans without a StandardMBean wrapper
--------------------------------------------------------------------
Key: JBMICROCONT-109
URL: http://jira.jboss.com/jira/browse/JBMICROCONT-109
Project: JBoss MicroContainer
Issue Type: Sub-task
Components: General
Reporter: Brian Stansberry
Assigned To: Brian Stansberry
Fix For: JBossMC_2_0_0 Beta
If a bean is already a valid MBean, it should be possible to directly register it in JMX without wrapping it in a StandardMBean. Otherwise beans that implement things like MBeanRegistration, NotificationBroadcaster, NotificationEmitter will not expose that API to the mbean server.
To support this, @JMX will add an attribute:
boolean registerDirectly() default false;
JMXIntroduction will check the attribute; if true the target bean will be registered directly; otherwise a StandardMBean will be created and registered.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
19 years
[JBoss JIRA] Created: (JBPORTAL-1091) CMS UI : order : for lists of languages, folders, files names
by Antoine Herzog (JIRA)
CMS UI : order : for lists of languages, folders, files names
-------------------------------------------------------------
Key: JBPORTAL-1091
URL: http://jira.jboss.com/jira/browse/JBPORTAL-1091
Project: JBoss Portal
Issue Type: Feature Request
Security Level: Public (Everyone can see)
Components: Portal CMS
Affects Versions: 2.4 Final
Environment: JBoss Portal 2.4, WXP, CMS repository in filesystem,
Reporter: Antoine Herzog
Assigned To: Roy Russo
Priority: Minor
In the CMS UI, the ordering of the folders and the files names is "Date of creation".
Wish : the ordering by names (more convenient to work).
even better : feature to choose the ordering on name, dates, description (second priority).
In the list of languages, when you use it with another user language than english, the list is in a very messy order :
I guess it is the order of the languages names in english, but showed in the "other language".
example : "english" is written "anglais" and can be found after "grec" (greek) and before "esperanto".
solution : order the list with the i18n label of each items.
even better : propose in top of list the few languages that are supported by the portal.
propose a one (or a few) strategie(s) of ordering.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
19 years
[JBoss JIRA] Created: (JBRULES-549) Better support for linebreaks in LHS
by Dirk Bergstrom (JIRA)
Better support for linebreaks in LHS
------------------------------------
Key: JBRULES-549
URL: http://jira.jboss.com/jira/browse/JBRULES-549
Project: JBoss Rules
Issue Type: Feature Request
Security Level: Public (Everyone can see)
Components: Drl Parser/Builder
Reporter: Dirk Bergstrom
Assigned To: Mark Proctor
I have some rules with very long LHS expressions. I'd like to split them across multiple lines for readability. However, the parser has limited support for breaks.
These work:
when
ObjectTypeName( p0_exit_epoch > (RUM.now()),
p0_exit_epoch > (RUM.daysAgo(7)) )
variable :
OtherObjectType($rlis : rlis -> (RUM.countFieldsMatching($rlis, "state", "dev-maybe") > 0))
These don't:
variable : OtherObjectType($rlis :
rlis -> (RUM.countFieldsMatching($rlis, "state", "dev-maybe") > 0))
variable : OtherObjectType(($rlis : rlis ->
(RUM.countFieldsMatching($rlis, "state", "dev-maybe") > 0))
variable : OtherObjectType($rlis : rlis -> (RUM.countFieldsMatching($rlis,
"state", "dev-maybe") > 0))
While I'm at it, I'd love to have support for multiline expressions in DSL files, but I can imagine that would be a bit harder...
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
19 years