Replace all uses of Channel.receive() with Receiver.receive() callbacks
-----------------------------------------------------------------------
Key: JGRP-412
URL: http://jira.jboss.com/jira/browse/JGRP-412
Project: JGroups
Issue Type: Task
Affects Versions: 2.4
Reporter: Bela Ban
Assigned To: Bela Ban
Fix For: 3.0
This includes removing PullPushAdapters and converting MessageDispatcher/RpcDispatcher to use Receiver instead of PullPushAdapter
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
Change signature of Channel.down() to return Object, rename downcall() to down()
--------------------------------------------------------------------------------
Key: JGRP-453
URL: http://jira.jboss.com/jira/browse/JGRP-453
Project: JGroups
Issue Type: Task
Affects Versions: 2.5
Reporter: Bela Ban
Assigned To: Bela Ban
Fix For: 3.0
We had to make Channel.down() return void, otherwise JGroups would not have been backwards compatible with JBoss 4.0.5
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
ChannelFactory should have only channel create methods
------------------------------------------------------
Key: JGRP-612
URL: http://jira.jboss.com/jira/browse/JGRP-612
Project: JGroups
Issue Type: Task
Affects Versions: 2.5, 2.6, 2.7, 2.x
Reporter: Vladimir Blagojevic
Assigned To: Bela Ban
Fix For: 3.0
ChannelFactory should not have setMultiplexerConfig methods but rather only create channel methods. Multiplexer configuration can be initialized through implementors constructor.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
Replace JChannelFactory with one based on the JBoss AS impl
-----------------------------------------------------------
Key: JGRP-1108
URL: https://jira.jboss.org/jira/browse/JGRP-1108
Project: JGroups
Issue Type: Task
Reporter: Brian Stansberry
Assignee: Brian Stansberry
Fix For: 3.0
As part of JGRP-612, modify JChannelFactory to work more like the JBAS JChannelFactory -- ensuring channels have a singleton name etc.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://jira.jboss.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
Remove deprecated system properties (non 'jboss' namespace)
-----------------------------------------------------------
Key: JGRP-513
URL: http://jira.jboss.com/jira/browse/JGRP-513
Project: JGroups
Issue Type: Task
Reporter: Brian Stansberry
Assigned To: Bela Ban
Priority: Minor
As discussed on http://wiki.jboss.org/wiki/Wiki.jsp?page=SystemProps there are a number of deprecated, 'legacy' system properties. This is just a JIRA entry to track remembering to clean them up.
This JIRA is for the non-'jboss' namespaced properties, which perhaps we would keep around longer than the 'jboss' ones.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira