[JBoss JIRA] (AS7-3623) mod_cluster schema 1.2
by Brian Stansberry (JIRA)
[ https://issues.jboss.org/browse/AS7-3623?page=com.atlassian.jira.plugin.s... ]
Brian Stansberry updated AS7-3623:
----------------------------------
Fix Version/s: 8.0.0.Alpha1
(was: 7.3.0.Alpha1)
> mod_cluster schema 1.2
> ----------------------
>
> Key: AS7-3623
> URL: https://issues.jboss.org/browse/AS7-3623
> Project: Application Server 7
> Issue Type: Feature Request
> Components: Clustering
> Affects Versions: 7.1.0.CR1
> Reporter: Radoslav Husar
> Assignee: Radoslav Husar
> Fix For: 8.0.0.Alpha1
>
>
> Changes to the schema
> * simplified names and sync in line with scheme recommendations
> * remove redundant <mod-cluster-config .. /> for good, everything should be element of the subsystem
> * fix load factor enum: no pool metric supported
> * make load-balancers configurable via socket-outbuound-group mechanism
> * add missing load-balancer properties to <proxies/>
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
13 years, 4 months
[JBoss JIRA] (AS7-6316) Review of AccessController and PrivilegedAction use across AS7
by Brian Stansberry (JIRA)
[ https://issues.jboss.org/browse/AS7-6316?page=com.atlassian.jira.plugin.s... ]
Brian Stansberry updated AS7-6316:
----------------------------------
Fix Version/s: 8.0.0.Alpha1
(was: 7.3.0.Alpha1)
> Review of AccessController and PrivilegedAction use across AS7
> --------------------------------------------------------------
>
> Key: AS7-6316
> URL: https://issues.jboss.org/browse/AS7-6316
> Project: Application Server 7
> Issue Type: Task
> Components: Security
> Reporter: Darran Lofthouse
> Assignee: Darran Lofthouse
> Priority: Critical
> Fix For: 8.0.0.Alpha1
>
>
> The following needs reviewing across AS7: -
> - On demand instantiation of PrivilegedActions where singletons would suffice (Consider frequency of calls, gc may be preferable).
> - Use of AccessController even though there is no SecurityManager set.
> - Code duplication, in every case I have seen so far the code is the same regardless of if PRIVILEGED or NON_PRIVILEGED
> - Utility methods with visibility too high.
> - In depth review of the other methods, i.e. if the first thing a public method does is set the class loader based on a parameter passed in it could be used badly - it may even be a justification for that method to NOT use a PrivilegedAction.
> - Code that requires to be executed using a PrivilegedAction should also be double checked that it is not doing too much as the identity of the caller.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
13 years, 4 months
[JBoss JIRA] (AS7-6503) Allow jconsole to be launched as a modular application
by Brian Stansberry (JIRA)
[ https://issues.jboss.org/browse/AS7-6503?page=com.atlassian.jira.plugin.s... ]
Brian Stansberry updated AS7-6503:
----------------------------------
Fix Version/s: 8.0.0.Alpha1
(was: 7.3.0.Alpha1)
> Allow jconsole to be launched as a modular application
> ------------------------------------------------------
>
> Key: AS7-6503
> URL: https://issues.jboss.org/browse/AS7-6503
> Project: Application Server 7
> Issue Type: Feature Request
> Components: JMX, Scripts
> Reporter: Brian Stansberry
> Fix For: 8.0.0.Alpha1
>
>
> Make the jconsole scripts launch jconsole as as a modular application. Get rid of the classpath building that resulted in AS7-6498.
> Some (mildly edited) discussion:
> bstansberry: BTW, I filed a JIRA to make the vault tool a proper modular app in AS next. I'm not sure if that's doable for jconsole
> [10:37am] darranl: bstansberry: Yes vault should be modular - I don't believe jconsole is as easily possible unless we add a module for the jconsole classes
> [10:38am] darranl: bstansberry: the problem with jconsole was that we actually needed to call jconsole which I think was a binary so we were just created an extended classpath for that binary to use
> [10:38am] bstansberry: darranl: ok, will do. I didn't file a JIRA for modular jconsole because I figured there would be problems
> [10:39am] darranl: bstansberry: having said that it may be possible now to just switch to use the client jar - that did not exist at the time the jconsole script was first written
> [10:40am] darranl: but at this point may be safer to just update the root of the modules folder and switch to client later
> [10:40am] bstansberry: darranl: this will become more of an issue once we have patching
> [10:40am] bstansberry: since this script won't pick up any patches we may have issued for the listed modules
> [10:40am] bstansberry: and no way are we going to add that to the script
> [10:43am] dmlloyd: I've booted jconsole from within modules before
> [10:43am] dmlloyd: it's possible
> [10:43am] darranl: If it is possbile then maybe we can just make it modular
> [10:44am] dmlloyd: java -jar ~/.m2/repository/org/jboss/modules/jboss-modules/1.1.4.GA/jboss-modules-1.1.4.GA.jar -jar ~/local/jdk/home/lib/jconsole.jar
> [10:44am] dmlloyd: easy as bananas
> [10:45am] dmlloyd: if you use -cp you can also add dependencies via -dep
> [10:45am] dmlloyd: or we could create a jconsole module from openjdk even
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
13 years, 4 months
[JBoss JIRA] (AS7-430) DomainController discovery system
by Brian Stansberry (JIRA)
[ https://issues.jboss.org/browse/AS7-430?page=com.atlassian.jira.plugin.sy... ]
Brian Stansberry updated AS7-430:
---------------------------------
Fix Version/s: 8.0.0.Alpha1
(was: 7.3.0.Alpha1)
> DomainController discovery system
> ---------------------------------
>
> Key: AS7-430
> URL: https://issues.jboss.org/browse/AS7-430
> Project: Application Server 7
> Issue Type: Task
> Components: Domain Management
> Reporter: Brian Stansberry
> Assignee: Farah Juma
> Fix For: 8.0.0.Alpha1
>
>
> Mechanism(s) by which a Host Controller finds a Domain Controller so it can begin the process of integrating into the domain.
> Task includes the host.xml schema elements to configure this, the domain object model classes behind those elements, and the actual implementation of discovery from both the ServerManager and DomainController sides.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
13 years, 4 months
[JBoss JIRA] (AS7-6046) Logging indicates "missing dependency" not the cause of the error.
by Brian Stansberry (JIRA)
[ https://issues.jboss.org/browse/AS7-6046?page=com.atlassian.jira.plugin.s... ]
Brian Stansberry updated AS7-6046:
----------------------------------
Fix Version/s: 8.0.0.Alpha1
(was: 7.3.0.Alpha1)
> Logging indicates "missing dependency" not the cause of the error.
> ------------------------------------------------------------------
>
> Key: AS7-6046
> URL: https://issues.jboss.org/browse/AS7-6046
> Project: Application Server 7
> Issue Type: Feature Request
> Components: Domain Management
> Affects Versions: 7.1.3.Final (EAP)
> Reporter: Paul Hinds
> Assignee: Brian Stansberry
> Fix For: 8.0.0.Alpha1
>
>
> If the Data sources config is incorrect so that the <driver> element does not match an existing driver, the error message is cryptic.
> JBAS014775: New missing/unsatisfied dependencies:
> service jboss.jdbc-driver.db2xa (missing) dependents: [service jboss.data-source.java:jboss/datasources/myDS]
> I would expect a log message at ERROR level, there is no error message while other data sources are loaded.
> Missing dependencies is printed on a line with no error level and the text of the message does not relate to the XML.
> I would expect the error message to indicate something about where to fix the error.
> e.g an XPath
> subsystem[xmlns="urn:jboss:domain:datasources:1.0"]/datasources/datasource/driver.
> or some text that indicates the <driver> element is the problem.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
13 years, 4 months