[JBoss JIRA] (WFLY-3816) ClassNotFoundException com.ibm.crypto.provider.IBMJCE with IBM JDK
by Jason Greene (JIRA)
[ https://issues.jboss.org/browse/WFLY-3816?page=com.atlassian.jira.plugin.... ]
Jason Greene updated WFLY-3816:
-------------------------------
Fix Version/s: 9.0.0.CR2
(was: 9.0.0.CR1)
> ClassNotFoundException com.ibm.crypto.provider.IBMJCE with IBM JDK
> ------------------------------------------------------------------
>
> Key: WFLY-3816
> URL: https://issues.jboss.org/browse/WFLY-3816
> Project: WildFly
> Issue Type: Bug
> Components: Class Loading
> Affects Versions: JBoss AS7 7.2.0.Final, 8.1.0.Final
> Environment: Linux / Aix ; IBM JDK 1.6
> Reporter: Yannick Lorenzati
> Assignee: Tomaz Cerar
> Priority: Minor
> Fix For: 9.0.0.CR2
>
>
> I use Jboss AS 7.2.0 with IBM JDK 1.6
> One of my applications try to load the security provider com.ibm.crypto.provider.IBMJCE but I got an ClassNotFoundException.
> I think it’s because in the ibm.jdk module.xml we need to add the package of the security provider like this
> <module xmlns="urn:jboss:module:1.1" name="ibm.jdk">
> <resources>
> </resources>
> <dependencies>
> <system export="true">
> <paths>
> <path name="com/ibm"/>
> <path name="com/ibm/jvm"/>
> <path name="com/ibm/jvm/io"/>
> <path name="com/ibm/jvm/util"/>
> <path name="com/ibm/match"/>
> <path name="com/ibm/misc"/>
> <path name="com/ibm/net"/>
> <path name="com/ibm/nio"/>
> <path name="com/ibm/nio/ch"/>
> <path name="com/ibm/security/auth"/>
> <path name="com/ibm/security/bootstrap"/>
> <path name="com/ibm/security/auth/module"/>
> <path name="com/ibm/security/util"/>
> </paths>
> </system>
> </dependencies>
> </module>
> We need to add this
> <path name="com/ibm/crypto"/>
> <path name="com/ibm/crypto/provider"/>
> Can't do a pull request at work, but i hope this help
--
This message was sent by Atlassian JIRA
(v6.3.15#6346)
11 years, 2 months
[JBoss JIRA] (WFLY-3860) Improve dependency handling in clustering/infinispan subsystem tests
by Jason Greene (JIRA)
[ https://issues.jboss.org/browse/WFLY-3860?page=com.atlassian.jira.plugin.... ]
Jason Greene updated WFLY-3860:
-------------------------------
Fix Version/s: 9.0.0.CR2
(was: 9.0.0.CR1)
> Improve dependency handling in clustering/infinispan subsystem tests
> --------------------------------------------------------------------
>
> Key: WFLY-3860
> URL: https://issues.jboss.org/browse/WFLY-3860
> Project: WildFly
> Issue Type: Task
> Components: Clustering
> Affects Versions: 9.0.0.Alpha1
> Reporter: Brian Stansberry
> Assignee: Brian Stansberry
> Fix For: 9.0.0.CR2
>
>
> The subsystem tests in clustering/infinispan are not configured to use a controller operating in --admin-only mode, but they are also not doing all the needed setup to have needed services and resources (core, jmx, jgroups) available for when the services they add are started.
> This is fragile, because all sorts of stuff is failing when things are getting launched, but the tests are not noticing that. That's ok right now, but it could lead to missing regressions.
> Also, the changes I'm making for WFCORE-102 mean these problems will no longer go unnoticed and the tests will fail.
> I plan to:
> 1) Shifts tests to using --admin-only in cases where the tests are clearly not testing anything related to runtime execution; i.e. they are just testing model.
> 2) For OperationSequencesTestCase and OperationsTestCase, where there is some validation of runtime behavior going on (explicit in some places; in others perhaps expected, perhaps not) I'm going to switch the tests to a more focused config file that:
> a) Only uses local caches, to avoid pulling in requirements for jgroups things that are not present. (I see no indication any of the tests are testing anything not present with local caches.)
> b) Uses start="LAZY". This means services will get registered, but not started. Not starting avoids detection of various missing dependencies, including a ModuleLoader dependency that I can't figure out how to satisfy.
> The tests can't be trying to validate any behavior when services start, because they've never been able to start. So LAZY is fine. Some tests do seem to be looking for problem related to service conflicts as resources are added/removed. These tests are still valid, because service conflicts happen as soon as services are installed, whether or not the services need to start.
--
This message was sent by Atlassian JIRA
(v6.3.15#6346)
11 years, 2 months
[JBoss JIRA] (WFLY-3859) Improve ChannelInstanceResourceDefinition.addChannelProtocolMetricsRegistrationStep
by Jason Greene (JIRA)
[ https://issues.jboss.org/browse/WFLY-3859?page=com.atlassian.jira.plugin.... ]
Jason Greene updated WFLY-3859:
-------------------------------
Fix Version/s: 9.0.0.CR2
(was: 9.0.0.CR1)
> Improve ChannelInstanceResourceDefinition.addChannelProtocolMetricsRegistrationStep
> -----------------------------------------------------------------------------------
>
> Key: WFLY-3859
> URL: https://issues.jboss.org/browse/WFLY-3859
> Project: WildFly
> Issue Type: Bug
> Components: Clustering
> Affects Versions: 9.0.0.Alpha1
> Reporter: Brian Stansberry
> Assignee: Brian Stansberry
> Priority: Minor
> Fix For: 9.0.0.CR2
>
>
> While debugging a test, I noticed this in the test's console output:
> ERROR: WFLYCTL0013: Operation ("some_operation_name") failed - address: ([("subsystem" => "jgroups")]) - failure description: "WFLYCTL0216: Management resource '[(\"subsystem\" => \"jgroups\")]' not found"
> Sep 16, 2014 9:29:35 AM org.jboss.as.controller.AbstractOperationContext executeStep
> That "some_operation_name" visible to users isn't so good.
> A simple fix is to use a more meaningful name.
--
This message was sent by Atlassian JIRA
(v6.3.15#6346)
11 years, 2 months