[JBoss JIRA] (DROOLS-2743) [DMN Designer] Download as toolbar button
by Michael Anstis (JIRA)
[ https://issues.jboss.org/browse/DROOLS-2743?page=com.atlassian.jira.plugi... ]
Michael Anstis commented on DROOLS-2743:
----------------------------------------
[~roger600] I could also simply provide a DMN specific implementation of {{ProjectEditorMenuSessionItems}} to inject a DMN specific implementation of {{ProjectDiagramEditorMenuItemsBuilder}} and use my own i18n however it seems an overkill.. open to suggestions of what you'd prefer :-)
> [DMN Designer] Download as toolbar button
> -----------------------------------------
>
> Key: DROOLS-2743
> URL: https://issues.jboss.org/browse/DROOLS-2743
> Project: Drools
> Issue Type: Bug
> Components: DMN Editor
> Affects Versions: 7.9.0.Final
> Reporter: Jozef Marko
> Assignee: Michael Anstis
> Priority: Minor
> Labels: drools-tools
>
> The stunner based designers contain "Download as" button. The problem of this button for DMN Designer is that it contains option "Download as BPMN" instead of "Download as DMN".
--
This message was sent by Atlassian JIRA
(v7.5.0#75005)
8 years
[JBoss JIRA] (WFWIP-61) Description of the elements in newly introduced microprofile-config-smallrye subsystem could be more informative
by Jan Stourac (JIRA)
[ https://issues.jboss.org/browse/WFWIP-61?page=com.atlassian.jira.plugin.s... ]
Jan Stourac updated WFWIP-61:
-----------------------------
Environment: git@github.com:jmesnil/wildfly.git:WFLY-10522_microprofile-config-smallrye_extension
> Description of the elements in newly introduced microprofile-config-smallrye subsystem could be more informative
> ----------------------------------------------------------------------------------------------------------------
>
> Key: WFWIP-61
> URL: https://issues.jboss.org/browse/WFWIP-61
> Project: WildFly WIP
> Issue Type: Bug
> Components: MP Config
> Environment: git@github.com:jmesnil/wildfly.git:WFLY-10522_microprofile-config-smallrye_extension
> Reporter: Jan Stourac
> Assignee: Jeff Mesnil
>
> Description of the elements in /subsystem=microprofile-config-smallrye could give more info, so far it states just:
> {code:title=/subsystem=microprofile-config-smallrye:read-resource-description}
> "config-source-provider" => {
> "description" => "Config Source Provider",
> "config-source" => {
> "description" => "Config Source",
> {code}
> Maybe adding also information about what those elements are used for could improve user experience, e.g.:
> {code}
> "config-source-provider" => {
> "description" => "Config Source Provider can be used to register own implementation for config-source with your specific way of configuration",
> "config-source" => {
> "description" => "Config Source contains configured configuration sources that are utilized for configuration",
> {code}
--
This message was sent by Atlassian JIRA
(v7.5.0#75005)
8 years
[JBoss JIRA] (WFWIP-61) Description of the elements in newly introduced microprofile-config-smallrye subsystem could be more informative
by Jan Stourac (JIRA)
[ https://issues.jboss.org/browse/WFWIP-61?page=com.atlassian.jira.plugin.s... ]
Jan Stourac updated WFWIP-61:
-----------------------------
Description:
Description of the elements in /subsystem=microprofile-config-smallrye could give more info, so far it states just:
{code:title=/subsystem=microprofile-config-smallrye:read-resource-description}
"config-source-provider" => {
"description" => "Config Source Provider",
"config-source" => {
"description" => "Config Source",
{code}
Maybe adding also information about what those elements are used for could improve user experience, e.g.:
{code}
"config-source-provider" => {
"description" => "Config Source Provider can be used to register own implementation for config-source with your specific way of configuration",
"config-source" => {
"description" => "Config Source contains configured configuration sources that are utilized for configuration",
{code}
was:
Description of the elements in /subsystem=microprofile-config-smallrye could give more info, so far it states just:
{code}
"config-source-provider" => {
"description" => "Config Source Provider",
"config-source" => {
"description" => "Config Source",
{code}
Maybe adding also information about what those elements are used for could improve user experience, e.g.:
{code}
"config-source-provider" => {
"description" => "Config Source Provider can be used to register own implementation for config-source with your specific way of configuration",
"config-source" => {
"description" => "Config Source contains configured configuration sources that are utilized for configuration",
{code}
> Description of the elements in newly introduced microprofile-config-smallrye subsystem could be more informative
> ----------------------------------------------------------------------------------------------------------------
>
> Key: WFWIP-61
> URL: https://issues.jboss.org/browse/WFWIP-61
> Project: WildFly WIP
> Issue Type: Bug
> Components: MP Config
> Reporter: Jan Stourac
> Assignee: Jeff Mesnil
>
> Description of the elements in /subsystem=microprofile-config-smallrye could give more info, so far it states just:
> {code:title=/subsystem=microprofile-config-smallrye:read-resource-description}
> "config-source-provider" => {
> "description" => "Config Source Provider",
> "config-source" => {
> "description" => "Config Source",
> {code}
> Maybe adding also information about what those elements are used for could improve user experience, e.g.:
> {code}
> "config-source-provider" => {
> "description" => "Config Source Provider can be used to register own implementation for config-source with your specific way of configuration",
> "config-source" => {
> "description" => "Config Source contains configured configuration sources that are utilized for configuration",
> {code}
--
This message was sent by Atlassian JIRA
(v7.5.0#75005)
8 years
[JBoss JIRA] (WFWIP-61) Description of the elements in newly introduced microprofile-config-smallrye subsystem could be more informative
by Jan Stourac (JIRA)
Jan Stourac created WFWIP-61:
--------------------------------
Summary: Description of the elements in newly introduced microprofile-config-smallrye subsystem could be more informative
Key: WFWIP-61
URL: https://issues.jboss.org/browse/WFWIP-61
Project: WildFly WIP
Issue Type: Bug
Components: MP Config
Reporter: Jan Stourac
Assignee: Jeff Mesnil
Description of the elements in /subsystem=microprofile-config-smallrye could give more info, so far it states just:
{code}
"config-source-provider" => {
"description" => "Config Source Provider",
"config-source" => {
"description" => "Config Source",
{code}
Maybe adding also information about what those elements are used for could improve user experience, e.g.:
{code}
"config-source-provider" => {
"description" => "Config Source Provider can be used to register own implementation for config-source with your specific way of configuration",
"config-source" => {
"description" => "Config Source contains configured configuration sources that are utilized for configuration",
{code}
--
This message was sent by Atlassian JIRA
(v7.5.0#75005)
8 years
[JBoss JIRA] (DROOLS-2750) [DMN Designer] Default cell symbols
by Jozef Marko (JIRA)
Jozef Marko created DROOLS-2750:
-----------------------------------
Summary: [DMN Designer] Default cell symbols
Key: DROOLS-2750
URL: https://issues.jboss.org/browse/DROOLS-2750
Project: Drools
Issue Type: Epic
Components: DMN Editor
Affects Versions: 7.9.0.Final
Reporter: Jozef Marko
Assignee: Michael Anstis
As a citizen developer, I want to build my decision logic with as small effort as possible. Especially I want to build the *valid* expressions with minimal interaction with the designer. For this reason the designer should fill in default values/symbols into cells where possible. This should help with DMN designer getting started experience.
In this epic we should discuss where is possible to fill some default values/symbols into expression cells.
h3. Context
I think no appropriate default value exists. Maybe with exception of the last row?
h3. Literal Expressions
My proposal would be:
- empty cell, if it is valid value for literal expression cell, if not
- value according to the column data type, 0 for number, today for date ...
h3. Decision table
- symbol *-* due to trisotext samples
h3. Function
Really not sure
h3. Relation
Really not sure
h3. Invocation
Really not sure
[~manstis] [~tirelli] [~tari_manga] could you please put your thoughts into comments? I filed this epic to follow agile process. Not saying something from description will happen. However if we will agree on some default values we can then file separate tasks for this epic. I f we agree it is not good idea, we will close the epic.
--
This message was sent by Atlassian JIRA
(v7.5.0#75005)
8 years
[JBoss JIRA] (DROOLS-2750) [DMN Designer] Default cell symbols
by Jozef Marko (JIRA)
[ https://issues.jboss.org/browse/DROOLS-2750?page=com.atlassian.jira.plugi... ]
Jozef Marko updated DROOLS-2750:
--------------------------------
Priority: Minor (was: Major)
> [DMN Designer] Default cell symbols
> -----------------------------------
>
> Key: DROOLS-2750
> URL: https://issues.jboss.org/browse/DROOLS-2750
> Project: Drools
> Issue Type: Epic
> Components: DMN Editor
> Affects Versions: 7.9.0.Final
> Reporter: Jozef Marko
> Assignee: Michael Anstis
> Priority: Minor
> Labels: drools-tools
>
> As a citizen developer, I want to build my decision logic with as small effort as possible. Especially I want to build the *valid* expressions with minimal interaction with the designer. For this reason the designer should fill in default values/symbols into cells where possible. This should help with DMN designer getting started experience.
> In this epic we should discuss where is possible to fill some default values/symbols into expression cells.
> h3. Context
> I think no appropriate default value exists. Maybe with exception of the last row?
> h3. Literal Expressions
> My proposal would be:
> - empty cell, if it is valid value for literal expression cell, if not
> - value according to the column data type, 0 for number, today for date ...
> h3. Decision table
> - symbol *-* due to trisotext samples
> h3. Function
> Really not sure
> h3. Relation
> Really not sure
> h3. Invocation
> Really not sure
> [~manstis] [~tirelli] [~tari_manga] could you please put your thoughts into comments? I filed this epic to follow agile process. Not saying something from description will happen. However if we will agree on some default values we can then file separate tasks for this epic. I f we agree it is not good idea, we will close the epic.
--
This message was sent by Atlassian JIRA
(v7.5.0#75005)
8 years
[JBoss JIRA] (JBVFS-206) [GSS](7.1.z) URL.getContent() returns VirtualFile instead of ImageProducer
by Tomas Hofman (JIRA)
[ https://issues.jboss.org/browse/JBVFS-206?page=com.atlassian.jira.plugin.... ]
Tomas Hofman commented on JBVFS-206:
------------------------------------
{{java.net.URLConnection#getContent()}} specifies that a content handler determined by the connection's contentType should be called to produce the content. {{VirtualFileURLConnection}} doesn't call any content handler and always returns {{VirtualFile}} instead. That leads to different object types being returned when called from a Wildfly deployment as opposed to clean java environment and possibly other application servers.
> [GSS](7.1.z) URL.getContent() returns VirtualFile instead of ImageProducer
> --------------------------------------------------------------------------
>
> Key: JBVFS-206
> URL: https://issues.jboss.org/browse/JBVFS-206
> Project: JBoss VFS
> Issue Type: Bug
> Affects Versions: 3.2.12.Final
> Environment: Windows XP
> Reporter: Tomas Hofman
> Assignee: Tomas Hofman
>
> URL.getContent() behaves differently within JBoss than it does in a normal JVM. In our case, when a jar is used in a normal JVM, URL.getContent() returns an ImageProducer. When the same jar is used from within JBoss, a VirtualFile is returned which then causes a ClassCastException.
> Note: This worked fine in JBoss 4.2.3.GA.
--
This message was sent by Atlassian JIRA
(v7.5.0#75005)
8 years