[JBoss JIRA] (WFWIP-208) openshift-common.sh executes CLI command against non-existing standalone.xml
by Jan Blizňák (Jira)
Jan Blizňák created WFWIP-208:
---------------------------------
Summary: openshift-common.sh executes CLI command against non-existing standalone.xml
Key: WFWIP-208
URL: https://issues.jboss.org/browse/WFWIP-208
Project: WildFly WIP
Issue Type: Bug
Components: OpenShift
Reporter: Jan Blizňák
Assignee: Brian Stansberry
Using image {{docker-registry.upshift.redhat.com/kwills/eap-cd-openshift-rhel8:18.0-EAP7-1216}} we are unable to build an application deployment that will need to setup a datasource, eg. executed with properties:
{code:java}
CUSTOM_INSTALL_DIRECTORIES=mypg_module,mypg_driver
DRIVERS=MYPG
MYPG_DRIVER_NAME=mypg
MYPG_DRIVER_MODULE=org.mypg
MYPG_XA_DATASOURCE_CLASS=org.postgresql.xa.PGXADataSource
{code}
The error in build log is (when executed with SCRIPT_DEBUG=true):
{code:java}
...
+ CLI_SCRIPT_FILE_FOR_EMBEDDED=/tmp/cli-configuration-script-1569488395.cli
+ echo 'embed-server --timeout=30 --server-config=standalone.xml --std-out=echo'
+ cat /opt/eap/bin/launch/drivers.cli
+ echo ''
+ echo stop-embedded-server
+ echo 'Configuring the server using embedded server'
Configuring the server using embedded server
++ date +%s%3N
+ start=1569488395421
+ eval /opt/eap/bin/jboss-cli.sh --file=/tmp/cli-configuration-script-1569488395.cli --properties=/tmp/cli-script-property.cli '&>/tmp/cli-script-output.cli'
++ /opt/eap/bin/jboss-cli.sh --file=/tmp/cli-configuration-script-1569488395.cli --properties=/tmp/cli-script-property.cli
error: build error: non-zero (13) exit code from docker-registry.upshift.redhat.com/kwills/eap-cd-openshift-rhel8:18.0-EAP...
{code}
The problematic script is /opt/eap/bin/launch/openshift-common.sh.
The problem here is that the script is trying to modify standalone.xml but there is no such file at the time of the execution, only standalone.openshift.xml exists.
I can also see that the config name is looked up in openshift-common.sh by:
{code:java}
SERVER_CONFIG=${WILDFLY_SERVER_CONFIGURATION:-standalone.xml}
{code}
and this variable is set in launch/launch-config.sh:
{code:java}
WILDFLY_SERVER_CONFIGURATION=standalone-openshift.xml
{code}
but according to build log launch/launch-config.sh is never executed or sourced so the wrong default value is used.
--
This message was sent by Atlassian Jira
(v7.13.8#713008)
6 years, 10 months
[JBoss JIRA] (WFLY-12595) Upgrade IronJacamar to 1.4.18.Final
by Ivo Studensky (Jira)
[ https://issues.jboss.org/browse/WFLY-12595?page=com.atlassian.jira.plugin... ]
Ivo Studensky moved JBEAP-17649 to WFLY-12595:
----------------------------------------------
Project: WildFly (was: JBoss Enterprise Application Platform)
Key: WFLY-12595 (was: JBEAP-17649)
Workflow: GIT Pull Request workflow (was: CDW with loose statuses v1)
Component/s: Build System
(was: Build System)
Affects Version/s: (was: 7.2.4.GA)
Fix Version/s: (was: 7.2.5.GA)
> Upgrade IronJacamar to 1.4.18.Final
> -----------------------------------
>
> Key: WFLY-12595
> URL: https://issues.jboss.org/browse/WFLY-12595
> Project: WildFly
> Issue Type: Component Upgrade
> Components: Build System
> Reporter: Ivo Studensky
> Assignee: Ivo Studensky
> Priority: Major
> Labels: downstream_dependency
>
--
This message was sent by Atlassian Jira
(v7.13.8#713008)
6 years, 10 months
[JBoss JIRA] (WFLY-12377) Document usage of JAXWS Client BOM in jaws-* quickstarts
by Eduardo Martins (Jira)
[ https://issues.jboss.org/browse/WFLY-12377?page=com.atlassian.jira.plugin... ]
Eduardo Martins updated WFLY-12377:
-----------------------------------
Description: All JAXWS Quickstarts should explain usage of the JAXWS Client BOM as the proper way to manage/use the dependencies in server, assuring compatibility with it. Traditionally this kind of guidance is done along the reference to the BOM is pom.xml (was: All JAXWS Quickstarts's readme.adoc should briefly introduce usage of the JAXWS Client BOM as the proper way to manage/use the dependencies in server, assuring compatibility with it. This new content should preferably be implemented through the import of a reusable section in /shared-docs.)
> Document usage of JAXWS Client BOM in jaws-* quickstarts
> --------------------------------------------------------
>
> Key: WFLY-12377
> URL: https://issues.jboss.org/browse/WFLY-12377
> Project: WildFly
> Issue Type: Enhancement
> Components: Quickstarts
> Reporter: Eduardo Martins
> Assignee: Eduardo Martins
> Priority: Major
>
> All JAXWS Quickstarts should explain usage of the JAXWS Client BOM as the proper way to manage/use the dependencies in server, assuring compatibility with it. Traditionally this kind of guidance is done along the reference to the BOM is pom.xml
--
This message was sent by Atlassian Jira
(v7.13.8#713008)
6 years, 10 months
[JBoss JIRA] (WFLY-12468) Rename BOMs artifactIds with javaee8-* to jakartaee8-*
by Eduardo Martins (Jira)
[ https://issues.jboss.org/browse/WFLY-12468?page=com.atlassian.jira.plugin... ]
Eduardo Martins commented on WFLY-12468:
----------------------------------------
Since it's a task that should not block WFLY I did "extract" the JBoss BOMs final update into a new JIRA JBEE-246, since it should be managed at JBEE project.
> Rename BOMs artifactIds with javaee8-* to jakartaee8-*
> ------------------------------------------------------
>
> Key: WFLY-12468
> URL: https://issues.jboss.org/browse/WFLY-12468
> Project: WildFly
> Issue Type: Sub-task
> Components: BOM, Quickstarts
> Reporter: Eduardo Martins
> Assignee: Eduardo Martins
> Priority: Blocker
>
> The following WildFly BOM artifactIds should be renamed to not include javaee, replacing it with jakartaee8:
> * wildfly-javaee8
> * wildfly-javaee8-with-tools
> Reference to renamed BOMs in Quickstarts project should also be updated.
--
This message was sent by Atlassian Jira
(v7.13.8#713008)
6 years, 10 months
[JBoss JIRA] (WFLY-12468) Rename BOMs artifactIds with javaee8-* to jakartaee8-*
by Eduardo Martins (Jira)
[ https://issues.jboss.org/browse/WFLY-12468?page=com.atlassian.jira.plugin... ]
Eduardo Martins updated WFLY-12468:
-----------------------------------
Description:
The following WildFly BOM artifactIds should be renamed to not include javaee, replacing it with jakartaee8:
* wildfly-javaee8
* wildfly-javaee8-with-tools
Reference to renamed BOMs in Quickstarts project should also be updated.
was:
The following WildFly BOM artifactIds should be renamed to not include javaee, replacing it with jakartaee8:
* wildfly-javaee8
* wildfly-javaee8-with-tools
Same should be done to the jboss javaee BOMs at https://github.com/jboss/jboss-javaee-specs, what should probably first be forked due to including javaee in its name too (to jboss/jboss-jakartaee-specs?).
Reference to renamed BOMs in Quickstarts project should also be updated.
> Rename BOMs artifactIds with javaee8-* to jakartaee8-*
> ------------------------------------------------------
>
> Key: WFLY-12468
> URL: https://issues.jboss.org/browse/WFLY-12468
> Project: WildFly
> Issue Type: Sub-task
> Components: BOM, Quickstarts
> Reporter: Eduardo Martins
> Assignee: Eduardo Martins
> Priority: Blocker
>
> The following WildFly BOM artifactIds should be renamed to not include javaee, replacing it with jakartaee8:
> * wildfly-javaee8
> * wildfly-javaee8-with-tools
> Reference to renamed BOMs in Quickstarts project should also be updated.
--
This message was sent by Atlassian Jira
(v7.13.8#713008)
6 years, 10 months
[JBoss JIRA] (JBEE-246) Jakarta EE BOMs
by Eduardo Martins (Jira)
Eduardo Martins created JBEE-246:
------------------------------------
Summary: Jakarta EE BOMs
Key: JBEE-246
URL: https://issues.jboss.org/browse/JBEE-246
Project: JBoss Enterprise Spec APIs
Issue Type: Enhancement
Components: jboss-javaee-specs
Reporter: Eduardo Martins
Assignee: Eduardo Martins
The following JBoss BOM artifactIds should be renamed to not include javaee, replacing it with jakartaee8:
jboss-javaee-8.0
jboss-javaee-web-8.0
jboss-javaee-all-8.0
Ideally this should be done on a new repo jboss/jboss-jakartaee-specs, forked from jboss/jboss-javaee-specs
--
This message was sent by Atlassian Jira
(v7.13.8#713008)
6 years, 10 months
[JBoss JIRA] (WFLY-12593) Jakarta update to Quickstarts docs
by Eduardo Martins (Jira)
Eduardo Martins created WFLY-12593:
--------------------------------------
Summary: Jakarta update to Quickstarts docs
Key: WFLY-12593
URL: https://issues.jboss.org/browse/WFLY-12593
Project: WildFly
Issue Type: Enhancement
Components: Quickstarts
Reporter: Eduardo Martins
Assignee: Eduardo Martins
Any references to Java EE, in Quickstart docs, should be updated wrt Jakarta EE.
--
This message was sent by Atlassian Jira
(v7.13.8#713008)
6 years, 10 months