[
http://jira.jboss.com/jira/browse/EJBTHREE-679?page=all ]
Roland R?z reopened EJBTHREE-679:
---------------------------------
http://jira.jboss.com/jira/browse/JBINSTALL-42
I think that the Properties Service is not sufficient to provide a different naming
convention. What I thought about was a way to plug in a different default naming
convention.
The interface could look like this:
public interface DefaultJndiNameProvider {
String getDefaultRemoteJndiName(Container container);
String getDefaultLocalJndiName(Container container);
}
Currently the org.jboss.ejb3.ProxyFactoryHelper uses the
[<earname>/]<ejbname>/[remote|local] naming convention. We use a different
naming convention to support multiple jboss instances which can use each other. With a
default jndi name provider we could get rid of the "pain" from configuring the
jndi name for each bean.
The implementation of the DefaultJndiNameProvider could be configured using a System
Property.
Configurable default naming conventions for ejb3 jndi bindings
--------------------------------------------------------------
Key: EJBTHREE-679
URL:
http://jira.jboss.com/jira/browse/EJBTHREE-679
Project: EJB 3.0
Issue Type: Feature Request
Reporter: Roland R?z
Assigned To: William DeCoste
Priority: Optional
Fix For: EJB 3.0 RC9 - FD
An Interface could provide the default jndi bingings. A system property or an MBean could
provide the implementation of this interface.
By providing a naming convention, the RemoteBinding annotation of the ejb's could be
omitted when there exist a naming convention so the deployment is simplified.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira