[
https://issues.jboss.org/browse/DROOLS-2706?page=com.atlassian.jira.plugi...
]
Stetson Robinson commented on DROOLS-2706:
------------------------------------------
[~ibek], what other assets besides rules will the scenario test then?
Regarding the name, I think the word "Test" needs to be there because users know
what a "test" is intuitively, but "simulation" takes some thought and
interpretation. A "simulation" and a "test" mean close to the same
thing in this context, so we should opt for the clearer term, which imo is
"test". And we should not say "simulation test" or "test
simulator", which are redundant. As I understand it, this feature is a way to test
that a scenario of conditions yields the expected results based on the rules user's
have created. So because of that, *Rule Scenario Test* or just *Scenario Test* or frankly
the existing name *Test Scenario* makes the most sense to me.
Is there any reason why we don't just leave this feature called *Test Scenario* as it
is? Why do we need to change the name and why does everyone keep suggesting
"simulation" as part of it? I assume I must be overlooking some aspect of this
feature.
New "Scenario Test" asset list option (UX)
------------------------------------------
Key: DROOLS-2706
URL:
https://issues.jboss.org/browse/DROOLS-2706
Project: Drools
Issue Type: Task
Components: Scenario Simulation and Testing
Reporter: Liz Clayton
Assignee: Liz Clayton
Labels: UX, UXTeam
As a practitioner - I want to be able to distinguish the new Scenario Test tool option,
from the existing one, within the Asset list so that I can quickly/easily create a test
using the new editor.
*Verification conditions:*
The new Scenario Test tool is distinguishable from the existing test tool within the
asset list, through visual inspection by the user (no hover/click required.)
Notes:
Need a way to identify "experimental" tools from existing (to be deprecated?)
tools. Solution might include distinct names for each, or parenthetical append (e.g.
"experimental, beta, preview...) Or visual indicator, such as an icon, flag, etc.
--
This message was sent by Atlassian JIRA
(v7.5.0#75005)