[
https://issues.jboss.org/browse/WFCORE-2620?page=com.atlassian.jira.plugi...
]
Romain Pelisse commented on WFCORE-2620:
----------------------------------------
[~ctomc] I'm working on a fix for this issue, but I would like to double check I'm
not misunderstanding something here: Am I right to assume that the
'defaultBufferPerRegion' value is actually the same thing as
'buffers-per-slice' ? If so, I would propose (and fill the PR separetly) that we
rename the field in the class buffersPerSlice just for clarity purpose...
Add ability to read computed runtime values of IO subsystem
buffer-pool attributes
----------------------------------------------------------------------------------
Key: WFCORE-2620
URL:
https://issues.jboss.org/browse/WFCORE-2620
Project: WildFly Core
Issue Type: Enhancement
Affects Versions: 3.0.0.Beta13
Reporter: Romain Pelisse
Assignee: Romain Pelisse
Original Estimate: 2 days
Remaining Estimate: 2 days
In IO subsystem there are some attributes which are calculated based on available system
resources if not explicitly specified. These attributes are:
* worker
** io-threads
** task-max-threads
* buffer-pool
** buffer-size
** buffers-per-slice
** direct-buffers
Currently these computed values are not visible for user in the subsystem configuration
even with include-runtime=true.
To show these runtime values would definitely improve UX.
Worker attributes are covered by EAP7-616 .
This issue is about buffer-pool attributes.
--
This message was sent by Atlassian JIRA
(v7.2.3#72005)