]
Radoslav Husar reassigned WFLY-5547:
------------------------------------
Assignee: Radoslav Husar (was: Paul Ferraro)
singleton-deployment-1.0.xsd file name violates the common naming
scheme
------------------------------------------------------------------------
Key: WFLY-5547
URL:
https://issues.jboss.org/browse/WFLY-5547
Project: WildFly
Issue Type: Feature Request
Components: Clustering
Reporter: Ladislav Thon
Assignee: Radoslav Husar
The singleton deployment schema file \[1\] is called {{singleton-deployment-1.0.xsd}} and
it uses
- a dash {{-}} as a separator between name an version,
- a period {{.}} as a delimiter in the version number.
This is inconsistent with all other schema files that use an underscore {{\_}} on both
places (well, there are _some_ schemas that also use a dash {{-}} between name and
version, but they are a minority). I believe that this file should be made consistent by
renaming it to {{singleton-deployment_1_0.xsd}}.
\[1\]
clustering/singleton/extension/src/main/resources/schema/singleton-deployment-1.0.xsd