[
http://jira.jboss.com/jira/browse/JBPORTAL-1524?page=comments#action_1237... ]
Thomas Heute commented on JBPORTAL-1524:
----------------------------------------
"It would break the current themes for people upgrading" : the sooner, the
better : later, it will be "to late, there are to many people relying on ...
It's already the case. We cannot break compatibility in 2.6 branch and 2.8 should
benefit from a new engine for this.
There are several levels of customization, just modifying the jsps (from my experience it
helps a lot of users, but of course not the people who have a visual identity), modifying
the layout, and modifying the PageCustomizerInterceptor.
I don't see what the login feature has to do with that, we are talking about
"looking pretty"
I will have another look at your code (next time, *please* send a diff, it's easier to
look at) because i really didn't see the benefits specially in terms of customization
(except changing the name of those special regions, that appear anywhere else and is
documented (i think)). (understanding the code is relative, and doesn't justify a
breaking change)
PageCustomizerInterceptor : regionName may be set in service
descriptor.
------------------------------------------------------------------------
Key: JBPORTAL-1524
URL:
http://jira.jboss.com/jira/browse/JBPORTAL-1524
Project: JBoss Portal
Issue Type: Feature Request
Security Level: Public(Everyone can see)
Components: Portal Core
Affects Versions: 2.6 CR3, 2.6 Final
Environment: JBP 2.6 CR3
Reporter: Antoine Herzog
Assigned To: Thomas Heute
Fix For: 2.6.2 Final
Attachments: PageCustomizerInterceptor - Patch.zip
About the PageCustomizerInterceptor : the 2 regionName may be set in service descriptor.
It is more customizable, when building/adapting a layout.
But the best of this is to understand better that this service is providing the content
for the two regions in the layout.
When looking at the layout, you can see the regionName='dashboardnav' defined for
the header...
But no region of this name in default-object.xml or pages descriptors !
After some file search, I found this label (dashboardnav) in the
PageCustomizerInterceptor.
It is not easy to understand what's going on in this service...
As this jsp injection is not very usual, it would be much more easy to understand
what's hapening if the region name would be customizable in the service descriptor.
It also allow to change the names in the layout jsp file : navigation is a word that is
in many place in the portal code and descriptor... not easy to follow the track of where
are things about these tabs.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira