On Thu, Dec 20, 2012 at 4:44 PM, Summers Pittman <supittma(a)redhat.com> wrote:
On 12/20/2012 08:29 AM, Matthias Wessendorf wrote:
> On Thu, Dec 20, 2012 at 2:16 PM, Christos Vasilakis <cvasilak(a)gmail.com>
>> Hi team,
>> as part of the API overhaul ticket for the next CR1 release, we are
suggesting a rename of the the AGRestAdapter to AGRESTAdapter. Because REST is more an
official term it can be used in the context. Typical examples in the iOS land:
>> NSURL (and not NSUrl)
>> NSHTTPCookie (and not NSHttpCookie)
>> What do you think?
> +1 on the renaming!
> Thinking a bit more on that... I am not 100% sure with: AGRESTAdapter
> The 'AGRESTAdapter' is basically a Pipe implementation for a restful
> connection.... not sure if we should honor that fact (pipe impl) into
> the name of the class;
> Hrm... hard :)
> One (odd) suggestion could be 'AGRESTfulPipeAdapter'
Why not AGRESTPipe?
I like it
>> A ticket has been already opened for this case, see 
>>  https://issues.jboss.org/browse/AEROGEAR-763
>>  https://issues.jboss.org/browse/AEROGEAR-765
>> aerogear-dev mailing list
aerogear-dev mailing list