On Thu, Dec 20, 2012 at 2:16 PM, Christos Vasilakis <cvasilak(a)gmail.com> wrote:
as part of the API overhaul ticket for the next CR1 release, we are suggesting that
in the 'remove' method in the Pipe object, we should pass the actual object rather
than the id. That is, because of >iOS familiarity (CoreData) , users expect a remove
to happen on an object  rather than the id of the object.
Even that JPA thing :) does it like that:
We can determine the final endpoint by using the "recordId"
property of the config object in iOS and the "RecordId annotation" in Android as
approaches (either by id or by object).
But irrelevant for the actual API, since that is an implementation detail ;-)
What do you think?
+1 on using the 'object', instead of an the recordId