[
http://jira.jboss.com/jira/browse/EJBTHREE-705?page=comments#action_12343357 ]
Roland R?z commented on EJBTHREE-705:
-------------------------------------
We need a different naming convention to support multiple jboss instances which can use
services from each other. The instances are linked to each other using jndi links und rely
on naming conventions.
With a pluggable jndi name provider we could get rid of the "pain" from
configuring the jndi name for each bean. It would be fine when the "Configuration by
Exception" rule applies also in more complex environments.
Pluggable default naming conventions for ejb3 jndi bindings
-----------------------------------------------------------
Key: EJBTHREE-705
URL:
http://jira.jboss.com/jira/browse/EJBTHREE-705
Project: EJB 3.0
Issue Type: Feature Request
Reporter: Roland R?z
Priority: Minor
Currently the org.jboss.ejb3.ProxyFactoryHelper uses the
[<earname>/]<ejbname>/[remote|local] naming convention.
An Interface could provide the default names for jndi binding when the deployer
doesn't provide them.
The interface could look like this:
public interface DefaultJndiNameProvider {
String getDefaultRemoteJndiName(Container container);
String getDefaultLocalJndiName(Container container);
}
The implementation of the DefaultJndiNameProvider could be configured using a System
Property.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira