[
https://issues.jboss.org/browse/DROOLS-4160?page=com.atlassian.jira.plugi...
]
Edoardo Vacchi updated DROOLS-4160:
-----------------------------------
Description:
enable model generation by default.
contextually rename properties as follows:
{code}
@Parameter(property = "kogito.codegen.rules", defaultValue =
"null") // defaults to true iff DRLs are present
private Boolean generateRules;
@Parameter(property = "kogito.codegen.processes", defaultValue =
"null") // defaults to true iff BPMN are present
private Boolean generateProcesses;
@Parameter(property = "kogito.sources.keep", defaultValue =
"false") // substitutes generateModel=WITHDRL
private boolean keepSources;
@Parameter(property = "kogito.di.enabled", defaultValue = "true")
private boolean dependencyInjection;
{code}
was:set YES as the default value for generateModel -- make sure it works as expected and
creates no conflicts (I recall conflicts with BPMN in KieBuilderImpl)
Enable DRL codegen by default, rename config properties
-------------------------------------------------------
Key: DROOLS-4160
URL:
https://issues.jboss.org/browse/DROOLS-4160
Project: Drools
Issue Type: Task
Reporter: Edoardo Vacchi
Assignee: Edoardo Vacchi
Priority: Major
Labels: drools-core, kogito, submarine
Fix For: 8.0.0.Final
enable model generation by default.
contextually rename properties as follows:
{code}
@Parameter(property = "kogito.codegen.rules", defaultValue =
"null") // defaults to true iff DRLs are present
private Boolean generateRules;
@Parameter(property = "kogito.codegen.processes", defaultValue =
"null") // defaults to true iff BPMN are present
private Boolean generateProcesses;
@Parameter(property = "kogito.sources.keep", defaultValue =
"false") // substitutes generateModel=WITHDRL
private boolean keepSources;
@Parameter(property = "kogito.di.enabled", defaultValue =
"true")
private boolean dependencyInjection;
{code}
--
This message was sent by Atlassian Jira
(v7.12.1#712002)