]
James Perkins updated WFCORE-842:
---------------------------------
Fix Version/s: 2.0.0.CR1
(was: 2.0.0.Beta5)
Rename CapabilityContext to CapabilityScope
-------------------------------------------
Key: WFCORE-842
URL:
https://issues.jboss.org/browse/WFCORE-842
Project: WildFly Core
Issue Type: Enhancement
Components: Domain Management
Reporter: Brian Stansberry
Assignee: Brian Stansberry
Fix For: 2.0.0.CR1
I used the interface name "CapabilityContext" for the thing that defines the
scope in which a capability is registered. Bad name, particularly now that the WFCORE-834
work has introduced a "CapabilityResolutionContext" object for storing temp data
used during capability resolution. The 834 thing is much more of a context.
So let's rename it to CapabilityScope.