[
https://issues.jboss.org/browse/ELY-258?page=com.atlassian.jira.plugin.sy...
]
Darran Lofthouse commented on ELY-258:
--------------------------------------
Modifications to the naming of either class potentially have a large impact, renaming
client.AuthenticationContext to client.ClientAuthenticationContext could also mean the
class 'AuthenticationContextConfigurationClient' becomes
'ClientAuthenticationContextConfigurationClient' !!
Renaming both to AuthenticationContext on the other hand has a number of issues: -
1 - Harder to open the correct class in an IDE
2 - Harder to reference the correct class in auto code completion
3 - If the two are ever used together one will have to be fully qualified.
On the basis that client.AuthenticationContext is the one likely to be used by application
developers and server.ServerAuthenticationContext is predominantly used within Elytron it
looks like it will be appropriate to keep the current naming pattern.
Inconsistent 'AuthenticationContext' naming.
--------------------------------------------
Key: ELY-258
URL:
https://issues.jboss.org/browse/ELY-258
Project: WildFly Elytron
Issue Type: Task
Components: API / SPI
Reporter: Darran Lofthouse
Assignee: Darran Lofthouse
Priority: Blocker
Fix For: 1.1.0.Beta2
Other classes in these packages should also be checked but essentially we have a client
and server package, the context in client is AuthenticationContext, the one in server is
ServerAuthenticationContext.
If they are ever likely to be both used together then unique names would be advisable,
otherwise they could both be 'AuthenticationContext'.
Wait till all engineers are off PTO before working on this one.
--
This message was sent by Atlassian JIRA
(v6.4.11#64026)