[
http://jira.jboss.com/jira/browse/JBAOP-373?page=comments#action_12364971 ]
Kabir Khan commented on JBAOP-373:
----------------------------------
Hi Flavia,
I noticed our naming is a bit off, but please read to the end before changing anything!
Part 1:
Construction.getConstructor()
ConstructorCall.getConstructor()
ConstructorExecution.getConstructor()
MethodCall.getMethod()
vs
FieldAccess.getAdvisedField() (I think this should be renamed getField())
MethodExecution.getAdvisedMethod() (I think this should be renamed getMethod())
Part 2:
MethodCalledByMethod.getCallingMethod() and ConstructorCalledByMethod.getCallingMethod()
vs
MethodCalledByConstructor.getCalling() and MethodCalledByConstructor.getCalling() (I think
these should be renamed getCallingConstructor())
I realise I am probably the one who came up with these names, but since you are looking at
it would you mind taking a look? If these cannot be renamed, in other words if these
methods exist in 1.5.x and are being called, then I think we will need to rename the
methods in the interfaces and create duplicate methods in the implementing classes. For
example:
interface MethodExecution
{
Method getMethod();
}
class MethodInfo implements MethodExecution
{
...
//keep this
public Method getAdvisedMethod()
{
return advisedMethod;
}
//add this
public Method getMethod()
{
return advisedMethod;
}
}
I am not 100% sure if this is public API, so this might not be necessary. let's sync
up tomorrow when you get online
Extract interfaces to be used for JoinPointInfo when used with
Before/After/Throwing
------------------------------------------------------------------------------------
Key: JBAOP-373
URL:
http://jira.jboss.com/jira/browse/JBAOP-373
Project: JBoss AOP
Issue Type: Task
Security Level: Public(Everyone can see)
Reporter: Kabir Khan
Assigned To: Flavia Rainone
Priority: Blocker
Fix For: 2.0.0.alpha5
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://jira.jboss.com/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira