[
https://jira.jboss.org/jira/browse/JBPORTAL-2441?page=com.atlassian.jira....
]
Bernard de Terwangne commented on JBPORTAL-2441:
------------------------------------------------
In JSR-286 on topic PLT.11.1.3 Extra Request Parameters
... It is the responsibility of the portal/portlet-container to
properly namespace these extra parameters to avoid name collisions with parameters the
portlets define ...
This topic clearly requires to tag containter specific request parameters. This ticket
just takes even more importance.
JBPC should not use common names for technical http parameter names
-------------------------------------------------------------------
Key: JBPORTAL-2441
URL:
https://jira.jboss.org/jira/browse/JBPORTAL-2441
Project: JBoss Portal
Issue Type: Bug
Security Level: Public(Everyone can see)
Affects Versions: Portlet-2.0.1
Environment: Any
Reporter: Bernard de Terwangne
Attachments: ControllerRequestParameterNames.java, URLParameterConstants.java
JBoss Portlet Container uses very common parameter names such as mode, action, resource,
type, portlet, ...
Such parameter name have a high risk of conflicting with portlet specific parameter
names.
Some names are also quite long such as "publicnavigationalstatechanges"
I suggest to replace them with shorter and tagged names.
Hopefully thanks to a good coding quality the only affected class for doinig so will be
org.jboss.portal.portlet.controller.impl.ControllerRequestParameterNames
I'll attach to this ticket an improved version of this class
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
https://jira.jboss.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira