]
Bernard de Terwangne updated JBPORTAL-2441:
-------------------------------------------
Attachment: URLParameterConstants.java
This file should in my optinioin be merged within ControllerRequestFactory that contains
most http parameter names
JBPC should not use common names for technical http parameter names
-------------------------------------------------------------------
Key: JBPORTAL-2441
URL:
https://jira.jboss.org/jira/browse/JBPORTAL-2441
Project: JBoss Portal
Issue Type: Bug
Security Level: Public(Everyone can see)
Affects Versions: Portlet-2.0.1
Environment: Any
Reporter: Bernard de Terwangne
Attachments: ControllerRequestParameterNames.java, URLParameterConstants.java
JBoss Portlet Container uses very common parameter names such as mode, action, resource,
type, portlet, ...
Such parameter name have a high risk of conflicting with portlet specific parameter
names.
Some names are also quite long such as "publicnavigationalstatechanges"
I suggest to replace them with shorter and tagged names.
Hopefully thanks to a good coding quality the only affected class for doinig so will be
org.jboss.portal.portlet.controller.impl.ControllerRequestParameterNames
I'll attach to this ticket an improved version of this class
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: