Following discussion on ML thread , and JIRA discussion  (sorry guys I catched up
the discussion late, I wasn’t watching the JIRa ticket so i didn’t get notifications) here
is the 2 gists we have:
1. DataSync (JS naming) 
2. SyncPipe(ios naming) 
I guess we should call them the same and agree on a name. I like to use ‘pipe’ in the
naming just to recall it’s async and going through network. I found DataSync a too generic
term which may lead to confusion. This is not the same object that will save data offline
and trigger sync.
Main differences are: in iOS one I defined a readAll method. Also for save/update I define
a third callbacks ‘conflict’ which take 3 arguments .
@summers do you have a gist for java API?