I'll be committing JBAS-5170 in a minute. Just a quick note on something I've
added to the resolution of this JIRA:
Together with the call to setSingletonName in HASingletonSupport, I'm also calling
setHAPartition(). As a result, pickSingleton(HAPartition) and isElectedMaster(HAPartition)
are effectively not needed for neither the standard nor the extended election policy
implementations.
So, I'm doing two things here:
- these methods delegate to their overload methods that have no parameters, i.e.
pickSingleton() and isElectedMaster()
- In HASingletonElectionPolicy, I'm deprecating pickSingleton(HAPartition) and
isElectedMaster(HAPartition) adding an explanation in the @deprecated javadoc.
The code is much more readable now :). If someone disagrees with this, I'll go back
and change it. For the time being, I'm committing this.
View the original post :
http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4144995#...
Reply to the post :
http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&a...