On 26 March 2014 20:20, Hardy Ferentschik <hardy(a)hibernate.org> wrote:
On 26 Jan 2014, at 21:07, Steve Ebersole <steve(a)hibernate.org> wrote:
> I also renamed @AccessType (out custom one) to be @AttributeAccessor to
> better avoid confusion with the JPA names.
+1 Definitely the better choice
I don't argue with that, but the context of my example was "assuming
my team has the convention of always putting mappings on properties",
so in such a case I'd want to use the second.
I really have no strong feeling against how you all think it should be
or any spec wording, my only concern is what happens when someone does
have a different interpretation or opinion. AFAIK today these are
ignored: would be nice to eventually be able to strictly validate (for
whatever decison you might take).
I think that's important to be taken into consideration while you work
on how Jandex reads things: to be able to provide strict validation,
you will need to be able to read annotations from both positions.