OK, got it.
The absence of this TargetedFields (or whatever name we could give it) interface would be
equivalent to allowSkipOnUnchangedField = false for a bridge. Likewise for DynamicBoost
Of course an additional interface is less in your face than an explicit method on the
I'm fully aligned. That looks like the best approach, but I don't like
it much to deal with complex hierarchies of interfaces - which need to
be well understood by users - and behave differently according to the
fact a method is defined or not.
It would be nice if we could enable optimisations more transparently,
but I see this looks like is the best we can do without going for the