"wolfc" wrote : We should not have a isVolatile on MethodInfo, but isBridge. In
theory it can change in the future.
No, isVolatile is legit.
Perhaps we can add isBridge, which would currently just call isVolatile for MethodInfo.
Once 'bridge' can be referenced via JDK, then we can change the impl.
| // Bits not (yet) exposed in the public API either because they
| // have different meanings for fields and methods and there is no
| // way to distinguish between the two in this class, or because
| // they are not Java programming language keywords
| static final int BRIDGE = 0x00000040;
|
View the original post :
http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4100412#...
Reply to the post :
http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&a...