+1 for everything in one file (except the forms themselves)
Sure it blurs the file to have namespaces, but creating 2 section introduces imo more
complexity than it solves. Besides, learning namespaces is easy
Maybe using namespaced attributes like e.g.
| <process-definition
| xmlns="urn:jbpm.org:jpdl-3.2"
| xmlns:gpd="urn:jbpm.org:jpdl-gpd-3.2"
| name="simple" gpd:width="469"
gpd:height="439"/>
| <state name="first" gpd:x="150" gpd:y="125"
gpd:width="140" gpd:height="40"/>
| <transition name="to_end" to="end">
| <action name="action"
class="com.sample.action.MessageActionHandler">
| <message>About to finish!</message>
| </action>
| </transition>
| </state>
| </process-definition>
|
is easier to read
Colors etc are a different thing... should they be included at all or configurable on a
higher level e.g. in the gpd, not de pd.
Maybe there it is an option to show/hide the gpd namespaced attributes when editing the
source
View the original post :
http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4043437#...
Reply to the post :
http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&a...