Jonathan Halliday [
http://community.jboss.org/people/jhalliday] replied to the discussion
"beanifying the config"
To view the discussion, visit:
http://community.jboss.org/message/534989#534989
--------------------------------------------------------------
Anyone going to complain if I break things? The current naming convention is:
String getFoo(); // returns a class name
but keeping that means introducing e.g.
Foo getFooInstance();
whereas I think we would be better off in the long run with
String getFooName() || String getFooClassname() || String getFooClassName()
Foo getFoo();
In the short term however that's going to break every existing config file. Again. I
can probably fix the jbossts-properties.xml ones by adding a kludge to the properties
loading code, but that still leaves a compatibility problem with existing -beans.xml
files.
--------------------------------------------------------------
Reply to this message by going to Community
[
http://community.jboss.org/message/534989#534989]
Start a new discussion in JBoss Transactions Development at Community
[
http://community.jboss.org/choose-container!input.jspa?contentType=1&...]