I just had a quick look at the latest code just checked in, and I have a few questions:
1) Why are the methods stop, start, restart, and the extra logic around
"messagesWaiting", and the extra server consumer start and stop necessary in the
ClientBrowserImpl?
Shouldn't the browsing consumer just behave exactly like a normal consumer?
2) On the server side, the method deliver and DeliverRunner class has been added to the
the ServerConsumerImpl, which duplicates code already in the QueueImpl.
A simpler solution would have been to take the copied Set of refs from the queue.list()
method, and then instantiate a QueueImpl instance on the fly and just have the consumer
consume from that, or create a simple class that just iterates the set and get it to call
the handle() method of ServerConsumer, then you wouldn't need to duplicate the code.
View the original post :
http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4182764#...
Reply to the post :
http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&a...