"timfox" wrote :
| What does "packetSize" represent?
|
Represents the memory necessary to be allocated before sending the packet.
This is particulary important on the InVM transport where we can't expand the buffer.
RemotingConnectionImpl is using that on my branch in order to allocate the buffer:
private void doWrite(final Packet packet)
| {
| final MessagingBuffer buffer =
transportConnection.createBuffer(packet.getPacketSize());
| packet.encode(buffer);
|
| transportConnection.write(buffer);
| }
|
|
"tim.fox" wrote : Confusing name. The journal is a large message?
| anonymous wrote :
| |
| | I will find a better name, but the idea is Journal has a LargeMessage. When we
have a DatabaseStorageManager we could have an implementation for the DB.
| | "Tim Fox" wrote :
| | | "Clebert" wrote :
| | | | III - I have separated the reference counting of references and durable
references on Messages (that fix on paging discussed on this thread:
http://www.jboss.com/index.html?module=bb&op=viewtopic&t=144128)
| | | |
| | | | As soon as we remove the reference from the queue (ACKs) I decrement the
refCount. I use that ref to delete large messages stored on files.
| | | |
| | |
| | | How is this different to how it was before?
| | |
| |
| | Before we only had the reference counting on Durables. Later I added another
counter for paging where I used to determine when the message was ready to GC, now the
same counter used for paging is also used to delete the message.
| |
| | For Paging I was returning the counter on the same place the durable was being
done (which is the weird code you noticed here
http://www.jboss.com/index.html?module=bb&op=viewtopic&t=144128).
| |
| | The refCount is only done now when the Message is removed from the Queue after
ACK.
| |
| | This was a simple fix!
| |
| |
| | anonymous wrote :
| | | For everyone's benefit could you explain what chunkSize represents, and
how it differs (or not) from minLargeMessageSize?
| | |
| |
| | I used to have two attributes (chunkSize and minLargeMessageSize), but I only have
minLargeMessageSize now.. so.. just scratch that name.
View the original post :
http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4185180#...
Reply to the post :
http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&a...