Ugh, though using this package convention means that hiding classes via
package-private is less appealing.
On Fri, Apr 16, 2010 at 3:17 PM, Lincoln Baxter, III <
lincolnbaxter(a)gmail.com> wrote:
I should add that I'm fine with using whatever packaging schema
the
Interceptor would reside in without such a convention, but this protects us
from refactoring, so I think it's a good idea.
--Lincoln
On Fri, Apr 16, 2010 at 3:16 PM, Lincoln Baxter, III <
lincolnbaxter(a)gmail.com> wrote:
> Ok - so this means we are back to square one. Can we discuss and agree on
> the following guidelines?
>
> All @Interceptor classes must:
>
> 1. Adhere to the following package and naming scheme:
> org.jboss.seam.intercept.*Interceptor
> 2. Warn users (or Error out when appropriate) if they are using
> interceptable @Annotations when the @Inteceptor itself is not registered,
> and provide instructions to correct the configuration:
>
> (@Interceptor registration can be checked in the Extension class
> AfterBeanDiscovery via BeanManager.resolveInterceptors(type,
> interceptorBindings)
>
> All @Decorator classes must:
>
> 1. Adhere to the following package and naming scheme:
> org.jboss.seam.decorate.*Decorator
>
> Let's discuss and resolve, since we're starting to release, and this is
> important. (Affects Faces directly.)
>
> Thanks,
> Lincoln
>
>
> On Mon, Apr 12, 2010 at 7:26 AM, Pete Muir <pmuir(a)redhat.com> wrote:
>
>>
>> On 11 Apr 2010, at 05:11, Gavin King wrote:
>>
>> > On Wed, Apr 7, 2010 at 7:23 AM, Pete Muir <pmuir(a)redhat.com> wrote:
>> >
>> >> BTW A slightly better approach (which avoids at least the nastiness of
>> this approach, but
>> >> doesn't avoid the issue of ordering - which IMO is insurmountable)
is
>> to write a
>> >> SeamInterceptor which can cope with using relative ordering semantics
>> and require users
>> >> to just enable that.
>> >
>> > Sure, but the problem is that then you can't interleave other
>> > interceptors with the Seam interceptors.
>>
>> Perhaps I should have prefaced it "a slightly better-than-terrible
way"
>> ;-)
>> _______________________________________________
>> seam-dev mailing list
>> seam-dev(a)lists.jboss.org
>>
https://lists.jboss.org/mailman/listinfo/seam-dev
>>
>
>
>
> --
> Lincoln Baxter, III
>
http://ocpsoft.com
>
http://scrumshark.com
> "Keep it Simple"
>
--
Lincoln Baxter, III
http://ocpsoft.com
http://scrumshark.com
"Keep it Simple"