after thinking a bit on +1 for Steve proposal
On 31 January 2017 at 08:09, Gunnar Morling <gunnar(a)hibernate.org> wrote:
Agreed, it'd be the right time if we wanted to change this.
I vote for 1 in case we do it.
In ORM it's enough for many use cases to just add that core module,
hence I like the more concise "hibernate-orm" id (similar to
"hibernate-validator"). It's a bit different for OGM and HSEARCH where
one needs core and typically another module with the NoSQL/indexing
backend (hence I like "hibernate-ogm-core" there).
2017-01-30 17:31 GMT+01:00 Steve Ebersole <steve(a)hibernate.org>:
> Relatedly, I have been thinking whether we want to rename the ORM
> as well since this is the best time if we wanted to do that.
> So we know we will change the groupId to `org.hibernate.orm`.
> I was thinking we might want to also either:
> 1. rename `hibernate-core` as `hibernate-orm`
> 2. rename all the artifacts following the pattern
> e.g. `hibernate-orm-core`, `hibernate-orm-osgi`, etc.
> On Mon, Jan 30, 2017 at 10:26 AM Steve Ebersole <steve(a)hibernate.org>
>> Well let's investigate what this consistency means across projects
>> As Sanne mentions, if it makes it building ORM more difficult then I'd
>> -1 it too. But I promise to take a peek when I get back from PTO in a
>> days. Or maybe Andrea can in the next few days as he already has
>> the changes to release relocation artifacts for ORM; I just do not know
>> when he is coming back from PTO. Either way we will have looked at it
>> ORM by the end of week.
>> On Mon, Jan 30, 2017 at 7:11 AM Guillaume Smet <
>> On Mon, Jan 30, 2017 at 2:01 PM, Sanne Grinovero <sanne(a)hibernate.org>
>> > Different projects have different needs. Consistency is nice, and
>> > certainly makes it easier to find oneself comfortably "at home"
>> > jumping from one project to another, but it also is inconvenient to do
>> > things "for consistency" when one has different requirements.
>> I don't think we would have different requirements regarding the
>> But if you see any issue with the approach we chose for HV, interesting
>> hearing them so that we can have the same approach for the different
>> hibernate-dev mailing list
> hibernate-dev mailing list
hibernate-dev mailing list